# CVE-2017-15806: Zeta Components Mail Arbitrary code execution via a crafted email address

> Remote attackers can execute arbitrary code via crafted email addresses in the Zeta Components Mail library due to insufficient character restriction in the return path.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hgr8-g756-vmg9

## What is CVE-2017-15806?

CVE-2017-15806 is a high-severity code injection vulnerability in n/a, published on 15 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The send function in the ezcMailMtaTransport class in Zeta Components Mail before 1.8.2 does not properly restrict the set of characters used in the ezcMail returnPath property, which might allow remote attackers to execute arbitrary code via a crafted email address, as demonstrated by one containing "-X/path/to/wwwroot/file.php."

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2017-15806?

2 open source packages ship an affected version, including zetacomponents/mail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zetacomponents/mail` | Packagist | All versions | 1.8.2 |
| `zetacomponents/mail` | Packagist | All versions | 1.8.2 |

Products: Zetacomponents Mail.

## How do I fix CVE-2017-15806?

Upgrade zetacomponents/mail to 1.8.2 or later.

## Is CVE-2017-15806 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-15806 exists.

Public exploit code:

- Zeta Components Mail 1.8.1 - Remote Code Execution (exploitdb)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15806 and fix it if it is affected.

What it is: CVE-2017-15806 is a high-severity code injection vulnerability in n/a, published on 15 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-15806 exists.

Affected packages and fixed versions:
- zetacomponents/mail (Packagist): affected all versions; fixed in 1.8.2
- zetacomponents/mail (Packagist): affected all versions; fixed in 1.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15806/ (Markdown: https://insights.sbomify.com/CVE-2017-15806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15806
- OSV: https://osv.dev/vulnerability/CVE-2017-15806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15806/
Summaries are generated and may contain mistakes; the official description above is the record.
