# CVE-2017-15878: Cross-Site Scripting in keystone

> An XSS vulnerability in KeystoneJS allows attackers to inject malicious scripts via the Contact Us feature, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7qcx-jmrc-h2rr

## What is CVE-2017-15878?

CVE-2017-15878 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting (XSS) vulnerability exists in fields/types/markdown/MarkdownType.js in KeystoneJS before 4.0.0-beta.7 via the Contact Us feature.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-15878?

2 open source packages ship an affected version, including keystone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keystone` | npm | All versions | 4.0.0 |
| `keystone` | npm | All versions | 4.0.0 |

Products: Keystonejs Keystone.

## How do I fix CVE-2017-15878?

Upgrade keystone to 4.0.0 or later.

## Is CVE-2017-15878 being exploited?

There is no known exploitation of CVE-2017-15878 in the wild and no public exploit code.

Public exploit code:

- KeystoneJS 4.0.0-beta.5 - Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2022-39382](https://insights.sbomify.com/CVE-2022-39382/): NODE_ENV in Keystone defaults to development with esbuild (critical 9.8)
- [CVE-2022-29354](https://insights.sbomify.com/CVE-2022-29354/): File upload in n/a (critical 9.8)
- [CVE-2022-39322](https://insights.sbomify.com/CVE-2022-39322/): @keystone-6/core vulnerable to field-level access-control bypass for multiselect field (critical 9.1)
- [CVE-2017-16570](https://insights.sbomify.com/CVE-2017-16570/): Cross-Site Request Forgery (CSRF) in keystone (high 8.8)
- [CVE-2017-15879](https://insights.sbomify.com/CVE-2017-15879/): Keystone is vulnerable to CSV injection (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15878 and fix it if it is affected.

What it is: CVE-2017-15878 is a medium-severity cross-site scripting vulnerability in n/a, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-15878 in the wild and no public exploit code.

Affected packages and fixed versions:
- keystone (npm): affected all versions; fixed in 4.0.0
- keystone (npm): affected all versions; fixed in 4.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15878/ (Markdown: https://insights.sbomify.com/CVE-2017-15878/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15878
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15878
- OSV: https://osv.dev/vulnerability/CVE-2017-15878

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15878/
Summaries are generated and may contain mistakes; the official description above is the record.
