# CVE-2017-15911: Ignite Realtime Openfire Server has Cross-site Scripting vulnerability in admin console

> An attacker can execute arbitrary JavaScript in the Openfire Admin Console via a crafted link, potentially stealing session IDs and bypassing CSRF protections.

- **Severity:** Medium 4.8 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Oct 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-v3h2-4j2r-wqj8

## What is CVE-2017-15911?

CVE-2017-15911 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Oct 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

The Admin Console in Ignite Realtime Openfire Server before 4.1.7 allows arbitrary client-side JavaScript code execution on victims who click a crafted setup/setup-host-settings.jsp?domain= link, aka XSS. Session ID and data theft may follow as well as the possibility of bypassing CSRF protections, injection of iframes to establish communication channels, etc. The vulnerability is present after login into the application.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-15911?

2 open source packages ship an affected version, including org.igniterealtime.openfire:parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.igniterealtime.openfire:parent` | Maven | All versions | 4.1.7 |
| `org.igniterealtime.openfire:parent` | Maven | All versions | 4.1.7 |

Products: Igniterealtime Openfire.

## How do I fix CVE-2017-15911?

Upgrade org.igniterealtime.openfire:parent to 4.1.7 or later.

## Is CVE-2017-15911 being exploited?

There is no known exploitation of CVE-2017-15911 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-32315](https://insights.sbomify.com/CVE-2023-32315/): Ignite Realtime Openfire Path Traversal (high 8.6, exploited in the wild)
- [CVE-2024-25421](https://insights.sbomify.com/CVE-2024-25421/): Ignite Realtime Openfire privilege escalation vulnerability (critical 9.8)
- [CVE-2021-45967](https://insights.sbomify.com/CVE-2021-45967/): Path traversal in n/a (critical 9.8)
- [CVE-2019-18394](https://insights.sbomify.com/CVE-2019-18394/): Ignite Realtime Openfire vulnerable to Server Side Request Forgery (critical 9.8)
- [CVE-2014-2741](https://insights.sbomify.com/CVE-2014-2741/): Ignite Realtime Openfire vulnerable to XMPPbomb attack (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15911 and fix it if it is affected.

What it is: CVE-2017-15911 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Oct 2017. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-15911 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 4.1.7
- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 4.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15911/ (Markdown: https://insights.sbomify.com/CVE-2017-15911/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15911
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15911
- OSV: https://osv.dev/vulnerability/CVE-2017-15911

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15911/
Summaries are generated and may contain mistakes; the official description above is the record.
