{"answers":{"affected":"3 open source packages ship an affected version, including borgbackup. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15914 in the wild and no public exploit code.","fix":"Upgrade borgbackup to 1.1.3 or later.","what":"CVE-2017-15914 is a high-severity missing authorization vulnerability in n/a, published on 8 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15914 and fix it if it is affected.\n\nWhat it is: CVE-2017-15914 is a high-severity missing authorization vulnerability in n/a, published on 8 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15914 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- borgbackup (PyPI): affected from 1.1.0b1; fixed in 1.1.3\n- borgbackup (PyPI): affected from 1.1.0b1; fixed in 1.1.3\n- borgbackup (PyPI): affected from 1.1.0b1; fixed in 1.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15914/ (Markdown: https://insights.sbomify.com/CVE-2017-15914/index.md)","id":"CVE-2017-15914","markdown":"https://insights.sbomify.com/CVE-2017-15914/index.md","name":"CVE-2017-15914","record":{"aliases":["DEBIAN-CVE-2017-15914","GHSA-8q8v-28rm-qw4w","PYSEC-2018-105"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Borg backup server","requires_auth":"low_privilege","summary":"Remote attackers can bypass repository restrictions in Borg servers to access or modify unauthorized backup data.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"borg","vendor":"borgbackup"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Borg Improper Access Control vulnerability","id":"CVE-2017-15914","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"Missing authorization in n/a","id":"CVE-2017-15917"},"packages":[{"ecosystem":"PyPI","fixed":["1.1.3"],"introduced":["1.1.0b1"],"last_affected":[],"package":"borgbackup","purl":null,"source":"GHSA-8q8v-28rm-qw4w"},{"ecosystem":"PyPI","fixed":["1.1.3"],"introduced":["1.1.0b1"],"last_affected":[],"package":"borgbackup","purl":"pkg:pypi/borgbackup","source":"GHSA-8q8v-28rm-qw4w"},{"ecosystem":"PyPI","fixed":["1.1.3"],"introduced":["1.1.0b1"],"last_affected":[],"package":"borgbackup","purl":"pkg:pypi/borgbackup","source":"PYSEC-2018-105"}],"prev":{"headline":"Other in n/a","id":"CVE-2017-15913"},"products":["n/a"],"published":"2018-02-08","related":[{"cvss_score":4.7,"headline":"Archive spoofing vulnerability in borgbackup","id":"CVE-2023-36811","kev_date_added":null,"published":"2023-08-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can bypass repository restrictions in Borg servers to access or modify unauthorized backup data.","url":"https://insights.sbomify.com/CVE-2017-15914/"}