# CVE-2017-15914: Borg Improper Access Control vulnerability

> Remote attackers can bypass repository restrictions in Borg servers to access or modify unauthorized backup data.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-15914, GHSA-8q8v-28rm-qw4w, PYSEC-2018-105

## What is CVE-2017-15914?

CVE-2017-15914 is a high-severity missing authorization vulnerability in n/a, published on 8 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect implementation of access controls allows remote users to override repository restrictions in Borg servers 1.1.x before 1.1.3.

## Which versions are affected by CVE-2017-15914?

3 open source packages ship an affected version, including borgbackup. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `borgbackup` | PyPI | From 1.1.0b1 | 1.1.3 |
| `borgbackup` | PyPI | From 1.1.0b1 | 1.1.3 |
| `borgbackup` | PyPI | From 1.1.0b1 | 1.1.3 |

Products: Borgbackup Borg.

## How do I fix CVE-2017-15914?

Upgrade borgbackup to 1.1.3 or later.

## Is CVE-2017-15914 being exploited?

There is no known exploitation of CVE-2017-15914 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-36811](https://insights.sbomify.com/CVE-2023-36811/): Archive spoofing vulnerability in borgbackup (medium 4.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15914 and fix it if it is affected.

What it is: CVE-2017-15914 is a high-severity missing authorization vulnerability in n/a, published on 8 Feb 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15914 in the wild and no public exploit code.

Affected packages and fixed versions:
- borgbackup (PyPI): affected from 1.1.0b1; fixed in 1.1.3
- borgbackup (PyPI): affected from 1.1.0b1; fixed in 1.1.3
- borgbackup (PyPI): affected from 1.1.0b1; fixed in 1.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15914/ (Markdown: https://insights.sbomify.com/CVE-2017-15914/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15914
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15914
- OSV: https://osv.dev/vulnerability/CVE-2017-15914

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15914/
Summaries are generated and may contain mistakes; the official description above is the record.
