{"answers":{"affected":"2 open source packages ship an affected version, including ox. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-15928 in the wild and no public exploit code.","fix":"Upgrade ox to 2.8.1 or later.","what":"CVE-2017-15928 is a high-severity denial of service vulnerability in n/a, published on 27 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-15928 and fix it if it is affected.\n\nWhat it is: CVE-2017-15928 is a high-severity denial of service vulnerability in n/a, published on 27 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-15928 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ox (RubyGems): affected all versions; fixed in 2.8.1\n- ox (RubyGems): affected all versions; fixed in 2.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-15928/ (Markdown: https://insights.sbomify.com/CVE-2017-15928/index.md)","id":"CVE-2017-15928","markdown":"https://insights.sbomify.com/CVE-2017-15928/index.md","name":"CVE-2017-15928","record":{"aliases":["DEBIAN-CVE-2017-15928","GHSA-pjj4-w39g-pw54","MGASA-2019-0123","UBUNTU-CVE-2017-15928"],"analysis":{"component_type":"library","fix_type":"no_fix_stated","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Ox gem","requires_auth":"none","summary":"A crafted input causes a segmentation fault in the Ox gem, leading to a denial of service for applications using the library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ox","vendor":"ox_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In the Ox gem 2.8.0 for Ruby, the process crashes with a segmentation fault when a crafted input is supplied to parse_obj. NOTE: the vendor has stated \"Ox should handle the error more gracefully\" but has not confirmed a security implication.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ox gem crashes due to a crafted input","id":"CVE-2017-15928","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Null dereference in n/a","id":"CVE-2017-15930"},"packages":[{"ecosystem":"RubyGems","fixed":["2.8.1"],"introduced":["0"],"last_affected":[],"package":"ox","purl":null,"source":"GHSA-pjj4-w39g-pw54"},{"ecosystem":"RubyGems","fixed":["2.8.1"],"introduced":["0"],"last_affected":[],"package":"ox","purl":"pkg:gem/ox","source":"GHSA-pjj4-w39g-pw54"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2017-15924"},"products":["n/a"],"published":"2017-10-27","related":[{"cvss_score":5.5,"headline":"Ox gem stack overflow in sax_parse","id":"CVE-2017-16229","kev_date_added":null,"published":"2018-02-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"A crafted input causes a segmentation fault in the Ox gem, leading to a denial of service for applications using the library.","url":"https://insights.sbomify.com/CVE-2017-15928/"}