# CVE-2017-15928: Ox gem crashes due to a crafted input

> A crafted input causes a segmentation fault in the Ox gem, leading to a denial of service for applications using the library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2017
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-15928, GHSA-pjj4-w39g-pw54, MGASA-2019-0123, UBUNTU-CVE-2017-15928

## What is CVE-2017-15928?

CVE-2017-15928 is a high-severity denial of service vulnerability in n/a, published on 27 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In the Ox gem 2.8.0 for Ruby, the process crashes with a segmentation fault when a crafted input is supplied to parse_obj. NOTE: the vendor has stated "Ox should handle the error more gracefully" but has not confirmed a security implication.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-15928?

2 open source packages ship an affected version, including ox. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ox` | RubyGems | All versions | 2.8.1 |
| `ox` | RubyGems | All versions | 2.8.1 |

Products: Ox Project Ox.

## How do I fix CVE-2017-15928?

Upgrade ox to 2.8.1 or later.

## Is CVE-2017-15928 being exploited?

There is no known exploitation of CVE-2017-15928 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-16229](https://insights.sbomify.com/CVE-2017-16229/): Ox gem stack overflow in sax_parse (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-15928 and fix it if it is affected.

What it is: CVE-2017-15928 is a high-severity denial of service vulnerability in n/a, published on 27 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-15928 in the wild and no public exploit code.

Affected packages and fixed versions:
- ox (RubyGems): affected all versions; fixed in 2.8.1
- ox (RubyGems): affected all versions; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-15928/ (Markdown: https://insights.sbomify.com/CVE-2017-15928/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-15928
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-15928
- OSV: https://osv.dev/vulnerability/CVE-2017-15928

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-15928/
Summaries are generated and may contain mistakes; the official description above is the record.
