# CVE-2017-16006: XSS in Data URI in remarkable

> Attackers can execute arbitrary JavaScript via data URIs in links, affecting applications using the Remarkable markdown parser.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-mrmf-qwxg-7c3h

## What is CVE-2017-16006?

CVE-2017-16006 is a medium-severity cross-site scripting vulnerability in HackerOne remarkable node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Remarkable is a markdown parser. In versions 1.6.2 and lower, remarkable allows the use of `data:` URIs in links and can therefore execute javascript.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-16006?

2 open source packages ship an affected version, including remarkable. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `remarkable` | npm | All versions | 1.7.0 |
| `remarkable` | npm | All versions | 1.7.0 |

Products: Remarkable Project Remarkable.

## How do I fix CVE-2017-16006?

Upgrade remarkable to 1.7.0 or later.

## Is CVE-2017-16006 being exploited?

There is no known exploitation of CVE-2017-16006 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne remarkable node module

- [CVE-2019-12041](https://insights.sbomify.com/CVE-2019-12041/): Regular Expression Denial of Service in remarkable (high 7.5)
- [CVE-2019-12043](https://insights.sbomify.com/CVE-2019-12043/): Cross-site Scripting in remarkable (medium 6.1)
- [CVE-2014-10065](https://insights.sbomify.com/CVE-2014-10065/): Content Injection in remarkable (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16006 and fix it if it is affected.

What it is: CVE-2017-16006 is a medium-severity cross-site scripting vulnerability in HackerOne remarkable node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16006 in the wild and no public exploit code.

Affected packages and fixed versions:
- remarkable (npm): affected all versions; fixed in 1.7.0
- remarkable (npm): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16006/ (Markdown: https://insights.sbomify.com/CVE-2017-16006/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16006
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16006
- OSV: https://osv.dev/vulnerability/CVE-2017-16006

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16006/
Summaries are generated and may contain mistakes; the official description above is the record.
