# CVE-2017-16007: Invalid Curve Attack in node-jose

> An attacker can recover private keys via an invalid curve attack when using ECDH-ES encryption in the node-jose library.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-rvj9-8cvx-3vq9

## What is CVE-2017-16007?

CVE-2017-16007 is a medium-severity vulnerability in HackerOne node-jose node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

node-jose is a JavaScript implementation of the JSON Object Signing and Encryption (JOSE) for current web browsers and node.js-based servers. node-jose earlier than version 0.9.3 is vulnerable to an invalid curve attack. This allows an attacker to recover the private secret key when JWE with Key Agreement with Elliptic Curve Diffie-Hellman Ephemeral Static (ECDH-ES) is used.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-16007?

2 open source packages ship an affected version, including node-jose. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-jose` | npm | All versions | 0.9.3 |
| `node-jose` | npm | All versions | 0.9.3 |

Products: Cisco Node-Jose.

## How do I fix CVE-2017-16007?

Upgrade node-jose to 0.9.3 or later.

## Is CVE-2017-16007 being exploited?

There is no known exploitation of CVE-2017-16007 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne node-jose node module

- [CVE-2023-25653](https://insights.sbomify.com/CVE-2023-25653/): Improper calculations in ECC implementation can trigger a Denial-of-Service (DoS) (high 7.5)
- [CVE-2018-0114](https://insights.sbomify.com/CVE-2018-0114/): Cisco node-jose improper validation of JWT signature (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16007 and fix it if it is affected.

What it is: CVE-2017-16007 is a medium-severity vulnerability in HackerOne node-jose node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16007 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-jose (npm): affected all versions; fixed in 0.9.3
- node-jose (npm): affected all versions; fixed in 0.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16007/ (Markdown: https://insights.sbomify.com/CVE-2017-16007/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16007
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16007
- OSV: https://osv.dev/vulnerability/CVE-2017-16007

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16007/
Summaries are generated and may contain mistakes; the official description above is the record.
