CVE-2017-16008 Cross-Site Scripting in i18next

Medium 6.1 Published Updated

Attackers can inject scripts into the browser via untrusted input in i18next due to flawed interpolation logic, affecting web applications using this library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-16008?

CVE-2017-16008 is a medium-severity cross-site scripting vulnerability in HackerOne i18next node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

i18next is a language translation framework. Because of how the interpolation is implemented, making replacements from the dictionary one at a time, untrusted user input can use the name of one of the dictionary keys to inject script into the browser. This affects i18next <=1.10.2.

Weakness: CWE-79

Which versions are affected by CVE-2017-16008?

2 open source packages ship an affected version, including i18next. It affects 1 product.

PackageAffectedFixed in
i18next npmAll versions1.10.3
i18next npmAll versions1.10.3

Products include I18next I18next.

How do I fix CVE-2017-16008?

Upgrade i18next to 1.10.3 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-16008 being exploited?

There is no known exploitation of CVE-2017-16008 in the wild and no public exploit code.

Sources

Also known as GHSA-f89g-whpf-6q9m.

Is CVE-2017-16008 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free