{"answers":{"affected":"2 open source packages ship an affected version, including i18next. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16008 in the wild and no public exploit code.","fix":"Upgrade i18next to 1.10.3 or later.","what":"CVE-2017-16008 is a medium-severity cross-site scripting vulnerability in HackerOne i18next node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-16008 and fix it if it is affected.\n\nWhat it is: CVE-2017-16008 is a medium-severity cross-site scripting vulnerability in HackerOne i18next node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-16008 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- i18next (npm): affected all versions; fixed in 1.10.3\n- i18next (npm): affected all versions; fixed in 1.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16008/ (Markdown: https://insights.sbomify.com/CVE-2017-16008/index.md)","id":"CVE-2017-16008","markdown":"https://insights.sbomify.com/CVE-2017-16008/index.md","name":"CVE-2017-16008","record":{"aliases":["GHSA-f89g-whpf-6q9m"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"i18next translation library","requires_auth":"none","summary":"Attackers can inject scripts into the browser via untrusted input in i18next due to flawed interpolation logic, affecting web applications using this library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"i18next","vendor":"i18next"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"i18next is a language translation framework. Because of how the interpolation is implemented, making replacements from the dictionary one at a time, untrusted user input can use the name of one of the dictionary keys to inject script into the browser. This affects i18next \u003c=1.10.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in i18next","id":"CVE-2017-16008","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"XSS via Angular Expression in ag-grid","id":"CVE-2017-16009"},"packages":[{"ecosystem":"npm","fixed":["1.10.3"],"introduced":["0"],"last_affected":[],"package":"i18next","purl":null,"source":"GHSA-f89g-whpf-6q9m"},{"ecosystem":"npm","fixed":["1.10.3"],"introduced":["0"],"last_affected":[],"package":"i18next","purl":"pkg:npm/i18next","source":"GHSA-f89g-whpf-6q9m"}],"prev":{"headline":"Invalid Curve Attack in node-jose","id":"CVE-2017-16007"},"products":["i18next node module"],"published":"2018-06-04","related":[{"cvss_score":6.1,"headline":"Cross-Site Scripting in i18next","id":"CVE-2017-16010","kev_date_added":null,"published":"2018-05-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can inject scripts into the browser via untrusted input in i18next due to flawed interpolation logic, affecting web applications using this library.","url":"https://insights.sbomify.com/CVE-2017-16008/"}