# CVE-2017-16008: Cross-Site Scripting in i18next

> Attackers can inject scripts into the browser via untrusted input in i18next due to flawed interpolation logic, affecting web applications using this library.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-f89g-whpf-6q9m

## What is CVE-2017-16008?

CVE-2017-16008 is a medium-severity cross-site scripting vulnerability in HackerOne i18next node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

i18next is a language translation framework. Because of how the interpolation is implemented, making replacements from the dictionary one at a time, untrusted user input can use the name of one of the dictionary keys to inject script into the browser. This affects i18next <=1.10.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-16008?

2 open source packages ship an affected version, including i18next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `i18next` | npm | All versions | 1.10.3 |
| `i18next` | npm | All versions | 1.10.3 |

Products: I18next I18next.

## How do I fix CVE-2017-16008?

Upgrade i18next to 1.10.3 or later.

## Is CVE-2017-16008 being exploited?

There is no known exploitation of CVE-2017-16008 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne i18next node module

- [CVE-2017-16010](https://insights.sbomify.com/CVE-2017-16010/): Cross-Site Scripting in i18next (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16008 and fix it if it is affected.

What it is: CVE-2017-16008 is a medium-severity cross-site scripting vulnerability in HackerOne i18next node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16008 in the wild and no public exploit code.

Affected packages and fixed versions:
- i18next (npm): affected all versions; fixed in 1.10.3
- i18next (npm): affected all versions; fixed in 1.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16008/ (Markdown: https://insights.sbomify.com/CVE-2017-16008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16008
- OSV: https://osv.dev/vulnerability/CVE-2017-16008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16008/
Summaries are generated and may contain mistakes; the official description above is the record.
