{"answers":{"affected":"2 open source packages ship an affected version, including i18next. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16010 in the wild and no public exploit code.","fix":"Upgrade i18next to 3.4.4 or later.","what":"CVE-2017-16010 is a medium-severity cross-site scripting vulnerability in HackerOne i18next node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-16010 and fix it if it is affected.\n\nWhat it is: CVE-2017-16010 is a medium-severity cross-site scripting vulnerability in HackerOne i18next node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-16010 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- i18next (npm): affected from 2.0.0; fixed in 3.4.4\n- i18next (npm): affected from 2.0.0; fixed in 3.4.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16010/ (Markdown: https://insights.sbomify.com/CVE-2017-16010/index.md)","id":"CVE-2017-16010","markdown":"https://insights.sbomify.com/CVE-2017-16010/index.md","name":"CVE-2017-16010","record":{"aliases":["GHSA-cmh5-qc8w-xvcq"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"i18next translation library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via XSS in i18next when interpolation options are configured without explicitly setting escapeValue to true.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"i18next","vendor":"i18next"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"i18next is a language translation framework. When using the .init method, passing interpolation options without passing an escapeValue will default to undefined rather than the assumed true. This can result in a cross-site scripting vulnerability because user input is assumed to be escaped, but is not. This vulnerability affects i18next 2.0.0 and later.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in i18next","id":"CVE-2017-16010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of Service via malformed accept-encoding header in hapi","id":"CVE-2017-16013"},"packages":[{"ecosystem":"npm","fixed":["3.4.4"],"introduced":["2.0.0"],"last_affected":[],"package":"i18next","purl":null,"source":"GHSA-cmh5-qc8w-xvcq"},{"ecosystem":"npm","fixed":["3.4.4"],"introduced":["2.0.0"],"last_affected":[],"package":"i18next","purl":"pkg:npm/i18next","source":"GHSA-cmh5-qc8w-xvcq"}],"prev":{"headline":"XSS via Angular Expression in ag-grid","id":"CVE-2017-16009"},"products":["i18next node module"],"published":"2018-05-29","related":[{"cvss_score":6.1,"headline":"Cross-Site Scripting in i18next","id":"CVE-2017-16008","kev_date_added":null,"published":"2018-06-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can execute arbitrary scripts via XSS in i18next when interpolation options are configured without explicitly setting escapeValue to true.","url":"https://insights.sbomify.com/CVE-2017-16010/"}