CVE-2017-16013 Denial of Service via malformed accept-encoding header in hapi
Attackers can crash the hapi web framework or hang connections by sending a malformed accept-encoding header, causing a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-16013?
CVE-2017-16013 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
hapi is a web and services application framework. When hapi >= 15.0.0 <= 16.1.0 encounters a malformed `accept-encoding` header an uncaught exception is thrown. This may cause hapi to crash or to hang the client connection until the timeout period is reached.
Which versions are affected by CVE-2017-16013?
2 open source packages ship an affected version, including hapi. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
hapi npm | From 15.0.0 | 16.1.1 |
hapi npm | From 15.0.0 | 16.1.1 |
Products include Hapijs Hapi.
How do I fix CVE-2017-16013?
Upgrade hapi to 16.1.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2017-16013 being exploited?
There is no known exploitation of CVE-2017-16013 in the wild and no public exploit code.
Other vulnerabilities in HackerOne hapi node module
Sources
Also known as GHSA-cqjg-whmm-8gv6.