{"answers":{"affected":"2 open source packages ship an affected version, including hapi. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16013 in the wild and no public exploit code.","fix":"Upgrade hapi to 16.1.1 or later.","what":"CVE-2017-16013 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16013 and fix it if it is affected.\n\nWhat it is: CVE-2017-16013 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16013 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- hapi (npm): affected from 15.0.0; fixed in 16.1.1\n- hapi (npm): affected from 15.0.0; fixed in 16.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16013/ (Markdown: https://insights.sbomify.com/CVE-2017-16013/index.md)","id":"CVE-2017-16013","markdown":"https://insights.sbomify.com/CVE-2017-16013/index.md","name":"CVE-2017-16013","record":{"aliases":["GHSA-cqjg-whmm-8gv6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js web framework","requires_auth":"none","summary":"Attackers can crash the hapi web framework or hang connections by sending a malformed accept-encoding header, causing a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"hapi","vendor":"hapijs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"hapi is a web and services application framework. When hapi \u003e= 15.0.0 \u003c= 16.1.0 encounters a malformed `accept-encoding` header an uncaught exception is thrown. This may cause hapi to crash or to hang the client connection until the timeout period is reached.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service via malformed accept-encoding header in hapi","id":"CVE-2017-16013","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Insufficient Error Handling in http-proxy","id":"CVE-2017-16014"},"packages":[{"ecosystem":"npm","fixed":["16.1.1"],"introduced":["15.0.0"],"last_affected":[],"package":"hapi","purl":null,"source":"GHSA-cqjg-whmm-8gv6"},{"ecosystem":"npm","fixed":["16.1.1"],"introduced":["15.0.0"],"last_affected":[],"package":"hapi","purl":"pkg:npm/hapi","source":"GHSA-cqjg-whmm-8gv6"}],"prev":{"headline":"Cross-Site Scripting in i18next","id":"CVE-2017-16010"},"products":["hapi node module"],"published":"2018-06-04","related":[{"cvss_score":7.5,"headline":"Denial of Service in hapi","id":"CVE-2015-9241","kev_date_added":null,"published":"2018-05-29"},{"cvss_score":5.9,"headline":"Unsafe Merging of CORS Configuration Conflict in hapi","id":"CVE-2015-9243","kev_date_added":null,"published":"2018-05-29"},{"cvss_score":5.3,"headline":"Incorrect handling of CORS preflight request headers in hapi","id":"CVE-2015-9236","kev_date_added":null,"published":"2018-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can crash the hapi web framework or hang connections by sending a malformed accept-encoding header, causing a denial of service.","url":"https://insights.sbomify.com/CVE-2017-16013/"}