# CVE-2017-16013: Denial of Service via malformed accept-encoding header in hapi

> Attackers can crash the hapi web framework or hang connections by sending a malformed accept-encoding header, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-cqjg-whmm-8gv6

## What is CVE-2017-16013?

CVE-2017-16013 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

hapi is a web and services application framework. When hapi >= 15.0.0 <= 16.1.0 encounters a malformed `accept-encoding` header an uncaught exception is thrown. This may cause hapi to crash or to hang the client connection until the timeout period is reached.

Weakness: CWE-20 (Improper Input Validation), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2017-16013?

2 open source packages ship an affected version, including hapi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hapi` | npm | From 15.0.0 | 16.1.1 |
| `hapi` | npm | From 15.0.0 | 16.1.1 |

Products: Hapijs Hapi.

## How do I fix CVE-2017-16013?

Upgrade hapi to 16.1.1 or later.

## Is CVE-2017-16013 being exploited?

There is no known exploitation of CVE-2017-16013 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne hapi node module

- [CVE-2015-9241](https://insights.sbomify.com/CVE-2015-9241/): Denial of Service in hapi (high 7.5)
- [CVE-2015-9243](https://insights.sbomify.com/CVE-2015-9243/): Unsafe Merging of CORS Configuration Conflict in hapi (medium 5.9)
- [CVE-2015-9236](https://insights.sbomify.com/CVE-2015-9236/): Incorrect handling of CORS preflight request headers in hapi (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16013 and fix it if it is affected.

What it is: CVE-2017-16013 is a high-severity denial of service vulnerability in HackerOne hapi node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16013 in the wild and no public exploit code.

Affected packages and fixed versions:
- hapi (npm): affected from 15.0.0; fixed in 16.1.1
- hapi (npm): affected from 15.0.0; fixed in 16.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16013/ (Markdown: https://insights.sbomify.com/CVE-2017-16013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16013
- OSV: https://osv.dev/vulnerability/CVE-2017-16013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16013/
Summaries are generated and may contain mistakes; the official description above is the record.
