{"answers":{"affected":"2 open source packages ship an affected version, including http-proxy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16014 in the wild and no public exploit code.","fix":"Upgrade http-proxy to 0.7.0 or later.","what":"CVE-2017-16014 is a high-severity denial of service vulnerability in HackerOne http-proxy node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16014 and fix it if it is affected.\n\nWhat it is: CVE-2017-16014 is a high-severity denial of service vulnerability in HackerOne http-proxy node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16014 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- http-proxy (npm): affected all versions; fixed in 0.7.0\n- http-proxy (npm): affected all versions; fixed in 0.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16014/ (Markdown: https://insights.sbomify.com/CVE-2017-16014/index.md)","id":"CVE-2017-16014","markdown":"https://insights.sbomify.com/CVE-2017-16014/index.md","name":"CVE-2017-16014","record":{"aliases":["GHSA-9xw9-pvgv-6p76"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js proxy library","requires_auth":"none","summary":"An attacker can crash the server by forcing an error in the http-proxy library, resulting in a denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"http-proxy","vendor":"http-proxy_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-388","name":null},{"id":"CWE-703","name":"Improper Check or Handling of Exceptional Conditions"}],"description":"Http-proxy is a proxying library. Because of the way errors are handled in versions before 0.7.0, an attacker that forces an error can crash the server, causing a denial of service.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficient Error Handling in http-proxy","id":"CVE-2017-16014","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-Site Scripting in forms","id":"CVE-2017-16015"},"packages":[{"ecosystem":"npm","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"http-proxy","purl":null,"source":"GHSA-9xw9-pvgv-6p76"},{"ecosystem":"npm","fixed":["0.7.0"],"introduced":["0"],"last_affected":[],"package":"http-proxy","purl":"pkg:npm/http-proxy","source":"GHSA-9xw9-pvgv-6p76"}],"prev":{"headline":"Denial of Service via malformed accept-encoding header in hapi","id":"CVE-2017-16013"},"products":["http-proxy node module"],"published":"2018-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"An attacker can crash the server by forcing an error in the http-proxy library, resulting in a denial of service.","url":"https://insights.sbomify.com/CVE-2017-16014/"}