{"answers":{"affected":"2 open source packages ship an affected version, including forms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16015 in the wild and no public exploit code.","fix":"Upgrade forms to 1.3.0 or later.","what":"CVE-2017-16015 is a medium-severity cross-site scripting vulnerability in HackerOne forms node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-16015 and fix it if it is affected.\n\nWhat it is: CVE-2017-16015 is a medium-severity cross-site scripting vulnerability in HackerOne forms node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-16015 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- forms (npm): affected all versions; fixed in 1.3.0\n- forms (npm): affected all versions; fixed in 1.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16015/ (Markdown: https://insights.sbomify.com/CVE-2017-16015/index.md)","id":"CVE-2017-16015","markdown":"https://insights.sbomify.com/CVE-2017-16015/index.md","name":"CVE-2017-16015","record":{"aliases":["GHSA-vwjj-2852-3765"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js forms library","requires_auth":"none","summary":"Attackers can inject malicious scripts via unsanitized form inputs in the Node.js forms library, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"forms","vendor":"forms_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"}],"description":"Forms is a library for easily creating HTML forms. Versions before 1.3.0 did not have proper html escaping. This means that if the application did not sanitize html on behalf of forms, use of forms may be vulnerable to cross site scripting","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in forms","id":"CVE-2017-16015","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-Site Scripting in sanitize-html","id":"CVE-2017-16016"},"packages":[{"ecosystem":"npm","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"forms","purl":null,"source":"GHSA-vwjj-2852-3765"},{"ecosystem":"npm","fixed":["1.3.0"],"introduced":["0"],"last_affected":[],"package":"forms","purl":"pkg:npm/forms","source":"GHSA-vwjj-2852-3765"}],"prev":{"headline":"Insufficient Error Handling in http-proxy","id":"CVE-2017-16014"},"products":["forms node module"],"published":"2018-06-04","related":[{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2021-23388","kev_date_added":null,"published":"2021-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can inject malicious scripts via unsanitized form inputs in the Node.js forms library, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2017-16015/"}