{"answers":{"affected":"2 open source packages ship an affected version, including sanitize-html. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16016 in the wild and no public exploit code.","fix":"Upgrade sanitize-html to 1.11.4 or later.","what":"CVE-2017-16016 is a medium-severity cross-site scripting vulnerability in HackerOne sanitize-html node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-16016 and fix it if it is affected.\n\nWhat it is: CVE-2017-16016 is a medium-severity cross-site scripting vulnerability in HackerOne sanitize-html node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-16016 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sanitize-html (npm): affected all versions; fixed in 1.11.4\n- sanitize-html (npm): affected all versions; fixed in 1.11.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16016/ (Markdown: https://insights.sbomify.com/CVE-2017-16016/index.md)","id":"CVE-2017-16016","markdown":"https://insights.sbomify.com/CVE-2017-16016/index.md","name":"CVE-2017-16016","record":{"aliases":["GHSA-xc6g-ggrc-qq4r","ROOT-APP-NPM-CVE-2017-16016"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js HTML sanitizer","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via XSS if non-text tags are allowed in the sanitize-html library configuration.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"sanitize-html","vendor":"punkave"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Sanitize-html is a library for scrubbing html input of malicious values. Versions 1.11.1 and below are vulnerable to cross site scripting (XSS) in certain scenarios: If allowed at least one nonTextTags, the result is a potential XSS vulnerability.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in sanitize-html","id":"CVE-2017-16016","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-Site Scripting in sanitize-html","id":"CVE-2017-16017"},"packages":[{"ecosystem":"npm","fixed":["1.11.4"],"introduced":["0"],"last_affected":[],"package":"sanitize-html","purl":null,"source":"GHSA-xc6g-ggrc-qq4r"},{"ecosystem":"npm","fixed":["1.11.4"],"introduced":["0"],"last_affected":[],"package":"sanitize-html","purl":"pkg:npm/sanitize-html","source":"GHSA-xc6g-ggrc-qq4r"}],"prev":{"headline":"Cross-Site Scripting in forms","id":"CVE-2017-16015"},"products":["sanitize-html node module"],"published":"2018-06-04","related":[{"cvss_score":6.1,"headline":"Cross-Site Scripting in sanitize-html","id":"CVE-2017-16017","kev_date_added":null,"published":"2018-06-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can execute arbitrary scripts via XSS if non-text tags are allowed in the sanitize-html library configuration.","url":"https://insights.sbomify.com/CVE-2017-16016/"}