# CVE-2017-16017: Cross-Site Scripting in sanitize-html

> Cross-site scripting vulnerability in sanitize-html allows attackers to inject malicious scripts into web pages viewed by other users.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-wg96-3933-j2w5

## What is CVE-2017-16017?

CVE-2017-16017 is a medium-severity cross-site scripting vulnerability in HackerOne sanitize-html node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

sanitize-html is a library for scrubbing html input for malicious values Versions 1.2.2 and below have a cross site scripting vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-16017?

2 open source packages ship an affected version, including sanitize-html. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sanitize-html` | npm | All versions | 1.2.3 |
| `sanitize-html` | npm | All versions | 1.2.3 |

Products: Punkave Sanitize-Html.

## How do I fix CVE-2017-16017?

Upgrade sanitize-html to 1.2.3 or later.

## Is CVE-2017-16017 being exploited?

There is no known exploitation of CVE-2017-16017 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne sanitize-html node module

- [CVE-2017-16016](https://insights.sbomify.com/CVE-2017-16016/): Cross-Site Scripting in sanitize-html (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16017 and fix it if it is affected.

What it is: CVE-2017-16017 is a medium-severity cross-site scripting vulnerability in HackerOne sanitize-html node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16017 in the wild and no public exploit code.

Affected packages and fixed versions:
- sanitize-html (npm): affected all versions; fixed in 1.2.3
- sanitize-html (npm): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16017/ (Markdown: https://insights.sbomify.com/CVE-2017-16017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16017
- OSV: https://osv.dev/vulnerability/CVE-2017-16017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16017/
Summaries are generated and may contain mistakes; the official description above is the record.
