CVE-2017-16018 Cross-Site Scripting (XSS) in restify
An attacker can execute arbitrary scripts in victim browsers via URL-encoded script tags in non-existent URLs using the Restify framework.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-16018?
CVE-2017-16018 is a medium-severity cross-site scripting vulnerability in HackerOne restify node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Restify is a framework for building REST APIs. Restify >=2.0.0 <=4.0.4 using URL encoded script tags in a non-existent URL, an attacker can get script to run in some browsers.
Weakness: CWE-79
Which versions are affected by CVE-2017-16018?
2 open source packages ship an affected version, including restify. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
restify npm | From 2.0.0 | 4.1.0 |
restify npm | From 2.0.0 | 4.1.0 |
Products include Restify Restify.
How do I fix CVE-2017-16018?
Upgrade restify to 4.1.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-16018 being exploited?
There is no known exploitation of CVE-2017-16018 in the wild and no public exploit code.
Sources
Also known as GHSA-qw3g-35hc-fcrh.