{"answers":{"affected":"2 open source packages ship an affected version, including uri-js. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16021 in the wild and no public exploit code.","fix":"Upgrade uri-js to 3.0.0 or later.","what":"CVE-2017-16021 is a medium-severity denial of service vulnerability in HackerOne uri-js node module, published on 4 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16021 and fix it if it is affected.\n\nWhat it is: CVE-2017-16021 is a medium-severity denial of service vulnerability in HackerOne uri-js node module, published on 4 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16021 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uri-js (npm): affected all versions; fixed in 3.0.0\n- uri-js (npm): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16021/ (Markdown: https://insights.sbomify.com/CVE-2017-16021/index.md)","id":"CVE-2017-16021","markdown":"https://insights.sbomify.com/CVE-2017-16021/index.md","name":"CVE-2017-16021","record":{"aliases":["GHSA-333w-rxj3-f55r"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript URI library","requires_auth":"low_privilege","summary":"Attackers can cause a denial of service by supplying malicious URLs to the uri-js library, leading to excessive CPU usage and application hangs.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"uri-js","vendor":"garycourt"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"uri-js is a module that tries to fully implement RFC 3986. One of these features is validating whether or not a supplied URL is valid or not. To do this, uri-js uses a regular expression, This regular expression is vulnerable to redos. This causes the program to hang and the CPU to idle at 100% usage while uri-js is trying to validate if the supplied URL is valid or not. To check if you're vulnerable, look for a call to `require(\"uri-js\").parse()` where a user is able to send their own input. This affects uri-js 2.1.1 and earlier.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial Of Service in uri-js","id":"CVE-2017-16021","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-Site Scripting in morris.js","id":"CVE-2017-16022"},"packages":[{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"uri-js","purl":null,"source":"GHSA-333w-rxj3-f55r"},{"ecosystem":"npm","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"uri-js","purl":"pkg:npm/uri-js","source":"GHSA-333w-rxj3-f55r"}],"prev":{"headline":"Unsafe eval() in summit allows arbitrary code execution","id":"CVE-2017-16020"},"products":["uri-js node module"],"published":"2018-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can cause a denial of service by supplying malicious URLs to the uri-js library, leading to excessive CPU usage and application hangs.","url":"https://insights.sbomify.com/CVE-2017-16021/"}