{"answers":{"affected":"2 open source packages ship an affected version, including decamelize. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16023 in the wild and no public exploit code.","fix":"Upgrade decamelize to 1.1.2 or later.","what":"CVE-2017-16023 is a high-severity denial of service vulnerability in HackerOne decamelize node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16023 and fix it if it is affected.\n\nWhat it is: CVE-2017-16023 is a high-severity denial of service vulnerability in HackerOne decamelize node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16023 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- decamelize (npm): affected from 1.1.0; fixed in 1.1.2\n- decamelize (npm): affected from 1.1.0; fixed in 1.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16023/ (Markdown: https://insights.sbomify.com/CVE-2017-16023/index.md)","id":"CVE-2017-16023","markdown":"https://insights.sbomify.com/CVE-2017-16023/index.md","name":"CVE-2017-16023","record":{"aliases":["GHSA-q5c4-39f5-m68j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js string utility","requires_auth":"none","summary":"Attackers can cause denial of service in the Decamelize library by providing unescaped separator values to its regular expression processing.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"decamelize","vendor":"decamelize_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Decamelize is used to convert a dash/dot/underscore/space separated string to camelCase. Decamelize 1.1.0 through 1.1.1 uses regular expressions to evaluate a string and takes unescaped separator values, which can be used to create a denial of service attack.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in decamelize","id":"CVE-2017-16023","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Tmp files readable by other users in sync-exec","id":"CVE-2017-16024"},"packages":[{"ecosystem":"npm","fixed":["1.1.2"],"introduced":["1.1.0"],"last_affected":[],"package":"decamelize","purl":null,"source":"GHSA-q5c4-39f5-m68j"},{"ecosystem":"npm","fixed":["1.1.2"],"introduced":["1.1.0"],"last_affected":[],"package":"decamelize","purl":"pkg:npm/decamelize","source":"GHSA-q5c4-39f5-m68j"}],"prev":{"headline":"Cross-Site Scripting in morris.js","id":"CVE-2017-16022"},"products":["decamelize node module"],"published":"2018-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can cause denial of service in the Decamelize library by providing unescaped separator values to its regular expression processing.","url":"https://insights.sbomify.com/CVE-2017-16023/"}