{"answers":{"affected":"2 open source packages ship an affected version, including nes. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16025 in the wild and no public exploit code.","fix":"Upgrade nes to 6.4.1 or later.","what":"CVE-2017-16025 is a medium-severity denial of service vulnerability in HackerOne nes node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16025 and fix it if it is affected.\n\nWhat it is: CVE-2017-16025 is a medium-severity denial of service vulnerability in HackerOne nes node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16025 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nes (npm): affected all versions; fixed in 6.4.1\n- nes (npm): affected all versions; fixed in 6.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16025/ (Markdown: https://insights.sbomify.com/CVE-2017-16025/index.md)","id":"CVE-2017-16025","markdown":"https://insights.sbomify.com/CVE-2017-16025/index.md","name":"CVE-2017-16025","record":{"aliases":["GHSA-3pwh-5mmc-mwrx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js WebSocket library","requires_auth":"none","summary":"An attacker can crash the Node.js process by sending an invalid cookie header during WebSocket upgrade when cookie authentication is enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"nes","vendor":"hapijs"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Nes is a websocket extension library for hapi. Hapi is a webserver framework. Versions below and including 6.4.0 have a denial of service vulnerability via an invalid Cookie header. This is only present when websocket authentication is set to `cookie`. Submitting an invalid cookie on the websocket upgrade request will cause the node process to error out.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of Service in nes","id":"CVE-2017-16025","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Remote Memory Exposure in request","id":"CVE-2017-16026"},"packages":[{"ecosystem":"npm","fixed":["6.4.1"],"introduced":["0"],"last_affected":[],"package":"nes","purl":null,"source":"GHSA-3pwh-5mmc-mwrx"},{"ecosystem":"npm","fixed":["6.4.1"],"introduced":["0"],"last_affected":[],"package":"nes","purl":"pkg:npm/nes","source":"GHSA-3pwh-5mmc-mwrx"}],"prev":{"headline":"Tmp files readable by other users in sync-exec","id":"CVE-2017-16024"},"products":["nes node module"],"published":"2018-06-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"An attacker can crash the Node.js process by sending an invalid cookie header during WebSocket upgrade when cookie authentication is enabled.","url":"https://insights.sbomify.com/CVE-2017-16025/"}