# CVE-2017-16026: Remote Memory Exposure in request

> An attacker can read non-zero memory contents by sending a multipart request with a numeric body type in the Request library.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** CLSA-2026-1785291220, DEBIAN-CVE-2017-16026, GHSA-7xfp-9c55-5vqj

## What is CVE-2017-16026?

CVE-2017-16026 is a medium-severity vulnerability in HackerOne request node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Request is an http client. If a request is made using ```multipart```, and the body type is a ```number```, then the specified number of non-zero memory is passed in the body. This affects Request >=2.2.6 <2.47.0 || >2.51.0 <=2.67.0.

Weakness: CWE-20 (Improper Input Validation), CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2017-16026?

4 open source packages ship an affected version, including request. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `request` | npm | From 2.2.6 | 2.68.0 |
| `request` | npm | From 2.2.6 | 2.68.0 |
| `request` | npm | From 2.49.0 | 2.68.0 |
| `request` | npm | From 2.49.0 | 2.68.0 |

Products: Request Project Request.

## How do I fix CVE-2017-16026?

Upgrade request to 2.68.0 or later.

## Is CVE-2017-16026 being exploited?

There is no known exploitation of CVE-2017-16026 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne request node module

- [CVE-2023-28155](https://insights.sbomify.com/CVE-2023-28155/): Server-Side Request Forgery in Request (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16026 and fix it if it is affected.

What it is: CVE-2017-16026 is a medium-severity vulnerability in HackerOne request node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16026 in the wild and no public exploit code.

Affected packages and fixed versions:
- request (npm): affected from 2.2.6; fixed in 2.68.0
- request (npm): affected from 2.2.6; fixed in 2.68.0
- request (npm): affected from 2.49.0; fixed in 2.68.0
- request (npm): affected from 2.49.0; fixed in 2.68.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16026/ (Markdown: https://insights.sbomify.com/CVE-2017-16026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16026
- OSV: https://osv.dev/vulnerability/CVE-2017-16026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16026/
Summaries are generated and may contain mistakes; the official description above is the record.
