# CVE-2017-16028: Cryptographically Weak PRNG in randomatic

> The library uses a weak random number generator for OAuth tokens, allowing attackers to predict tokens and bypass authentication.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-6g33-f262-xjp4

## What is CVE-2017-16028?

CVE-2017-16028 is a medium-severity vulnerability in HackerOne react-native-meteor-oauth node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

react-native-meteor-oauth is a library for Oauth2 login to a Meteor server in React Native. The oauth Random Token is generated using a non-cryptographically strong RNG (Math.random()).

Weakness: CWE-338 (Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)), CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2017-16028?

2 open source packages ship an affected version, including randomatic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `randomatic` | npm | All versions | 3.0.0 |
| `randomatic` | npm | All versions | 3.0.0 |

Products: Randomatic Project Randomatic.

## How do I fix CVE-2017-16028?

Upgrade randomatic to 3.0.0 or later.

## Is CVE-2017-16028 being exploited?

There is no known exploitation of CVE-2017-16028 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16028 and fix it if it is affected.

What it is: CVE-2017-16028 is a medium-severity vulnerability in HackerOne react-native-meteor-oauth node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16028 in the wild and no public exploit code.

Affected packages and fixed versions:
- randomatic (npm): affected all versions; fixed in 3.0.0
- randomatic (npm): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16028/ (Markdown: https://insights.sbomify.com/CVE-2017-16028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16028
- OSV: https://osv.dev/vulnerability/CVE-2017-16028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16028/
Summaries are generated and may contain mistakes; the official description above is the record.
