# CVE-2017-16029: Directory Traversal in hostr

> An attacker can read arbitrary files outside the served directory by manipulating URL paths in the hostr Node.js module.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-xqqr-p362-6rmc

## What is CVE-2017-16029?

CVE-2017-16029 is a high-severity path traversal vulnerability in HackerOne hostr node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

hostr is a simple web server that serves up the contents of the current directory. There is a directory traversal vulnerability in hostr 2.3.5 and earlier that allows an attacker to read files outside the current directory by sending `../` in the url path for GET requests.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-16029?

2 open source packages ship an affected version, including hostr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hostr` | npm | All versions | 2.3.6 |
| `hostr` | npm | All versions | 2.3.6 |

Products: Hostr Project Hostr.

## How do I fix CVE-2017-16029?

Upgrade hostr to 2.3.6 or later.

## Is CVE-2017-16029 being exploited?

There is no known exploitation of CVE-2017-16029 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16029 and fix it if it is affected.

What it is: CVE-2017-16029 is a high-severity path traversal vulnerability in HackerOne hostr node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16029 in the wild and no public exploit code.

Affected packages and fixed versions:
- hostr (npm): affected all versions; fixed in 2.3.6
- hostr (npm): affected all versions; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16029/ (Markdown: https://insights.sbomify.com/CVE-2017-16029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16029
- OSV: https://osv.dev/vulnerability/CVE-2017-16029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16029/
Summaries are generated and may contain mistakes; the official description above is the record.
