# CVE-2017-16030: ReDoS via long UserAgent header in useragent

> An attacker can cause a denial of service by sending an arbitrarily long user-agent string, blocking the server event loop.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-pjmx-9xr3-82qr

## What is CVE-2017-16030?

CVE-2017-16030 is a high-severity denial of service vulnerability in HackerOne useragent node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Useragent is used to parse useragent headers. It uses several regular expressions to accomplish this. An attacker could edit their own headers, creating an arbitrarily long useragent string, causing the event loop and server to block. This affects Useragent 2.1.12 and earlier.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2017-16030?

2 open source packages ship an affected version, including useragent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `useragent` | npm | All versions | 2.1.13 |
| `useragent` | npm | All versions | 2.1.13 |

Products: Useragent Project Useragent.

## How do I fix CVE-2017-16030?

Upgrade useragent to 2.1.13 or later.

## Is CVE-2017-16030 being exploited?

There is no known exploitation of CVE-2017-16030 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne useragent node module

- [CVE-2020-26311](https://insights.sbomify.com/CVE-2020-26311/): GHSL-2020-312: Regular Expression Denial of Service (ReDoS) in useragent (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16030 and fix it if it is affected.

What it is: CVE-2017-16030 is a high-severity denial of service vulnerability in HackerOne useragent node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16030 in the wild and no public exploit code.

Affected packages and fixed versions:
- useragent (npm): affected all versions; fixed in 2.1.13
- useragent (npm): affected all versions; fixed in 2.1.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16030/ (Markdown: https://insights.sbomify.com/CVE-2017-16030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16030
- OSV: https://osv.dev/vulnerability/CVE-2017-16030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16030/
Summaries are generated and may contain mistakes; the official description above is the record.
