# CVE-2017-16031: Insecure randomness in socket.io

> Predictable socket IDs allow attackers to hijack connections and access sensitive data on Socket.io servers.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-qv2v-m59f-v5fw

## What is CVE-2017-16031?

CVE-2017-16031 is a high-severity vulnerability in HackerOne socket.io node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Socket.io is a realtime application framework that provides communication via websockets. Because socket.io 0.9.6 and earlier depends on `Math.random()` to create socket IDs, the IDs are predictable. An attacker is able to guess the socket ID and gain access to socket.io servers, potentially obtaining sensitive information.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2017-16031?

2 open source packages ship an affected version, including socket.io. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `socket.io` | npm | All versions | 0.9.7 |
| `socket.io` | npm | All versions | 0.9.7 |

Products: Socket Socket.io.

## How do I fix CVE-2017-16031?

Upgrade socket.io to 0.9.7 or later.

## Is CVE-2017-16031 being exploited?

There is no known exploitation of CVE-2017-16031 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne socket.io node module

- [CVE-2020-28481](https://insights.sbomify.com/CVE-2020-28481/): Insecure Defaults (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16031 and fix it if it is affected.

What it is: CVE-2017-16031 is a high-severity vulnerability in HackerOne socket.io node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16031 in the wild and no public exploit code.

Affected packages and fixed versions:
- socket.io (npm): affected all versions; fixed in 0.9.7
- socket.io (npm): affected all versions; fixed in 0.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16031/ (Markdown: https://insights.sbomify.com/CVE-2017-16031/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16031
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16031
- OSV: https://osv.dev/vulnerability/CVE-2017-16031

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16031/
Summaries are generated and may contain mistakes; the official description above is the record.
