CVE-2017-16042 Growl before 1.10.0 vulnerable to Command Injection

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2017-16042?

CVE-2017-16042 is a critical vulnerability in HackerOne growl node module, published on 4 Jun 2018.

Official description

Growl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.

Weakness: CWE-78, CWE-94

Which versions are affected by CVE-2017-16042?

2 open source packages ship an affected version, including growl. It affects 1 product.

PackageAffectedFixed in
growl npmAll versions1.10.0
growl npmAll versions1.10.0

Products include Growl Project Growl.

How do I fix CVE-2017-16042?

Upgrade growl to 1.10.0 or later.

Is CVE-2017-16042 being exploited?

There is no known exploitation of CVE-2017-16042 in the wild and no public exploit code.

Sources

Also known as AZL-44547, CLSA-2026-1773620196, DEBIAN-CVE-2017-16042, GHSA-qh2h-chj9-jffq, UBUNTU-CVE-2017-16042.

Is CVE-2017-16042 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free