# CVE-2017-16042: Growl before 1.10.0 vulnerable to Command Injection


- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-44547, CLSA-2026-1773620196, DEBIAN-CVE-2017-16042, GHSA-qh2h-chj9-jffq, UBUNTU-CVE-2017-16042

## What is CVE-2017-16042?

CVE-2017-16042 is a critical vulnerability in HackerOne growl node module, published on 4 Jun 2018. 

### Official description

Growl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2017-16042?

2 open source packages ship an affected version, including growl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `growl` | npm | All versions | 1.10.0 |
| `growl` | npm | All versions | 1.10.0 |

Products: Growl Project Growl.

## How do I fix CVE-2017-16042?

Upgrade growl to 1.10.0 or later.

## Is CVE-2017-16042 being exploited?

There is no known exploitation of CVE-2017-16042 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16042 and fix it if it is affected.

What it is: CVE-2017-16042 is a critical vulnerability in HackerOne growl node module, published on 4 Jun 2018. 
Exploitation: There is no known exploitation of CVE-2017-16042 in the wild and no public exploit code.

Affected packages and fixed versions:
- growl (npm): affected all versions; fixed in 1.10.0
- growl (npm): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16042/ (Markdown: https://insights.sbomify.com/CVE-2017-16042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16042
- OSV: https://osv.dev/vulnerability/CVE-2017-16042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16042/
Summaries are generated and may contain mistakes; the official description above is the record.
