# CVE-2017-16043: HTML Injection in shout

> Attackers can inject HTML scripts via the /topic command in Shout IRC client, leading to code execution in the victim's browser.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-26q7-g57v-mxcp

## What is CVE-2017-16043?

CVE-2017-16043 is a medium-severity cross-site scripting vulnerability in HackerOne shout node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Shout is an IRC client. Because the `/topic` command in messages is unescaped, attackers have the ability to inject HTML scripts that will run in the victim's browser. Affects shout >=0.44.0 <=0.49.3.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2017-16043?

2 open source packages ship an affected version, including shout. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shout` | npm | From 0.44.0 | 0.50.0 |
| `shout` | npm | From 0.44.0 | 0.50.0 |

Products: Shout Project Shout.

## How do I fix CVE-2017-16043?

Upgrade shout to 0.50.0 or later.

## Is CVE-2017-16043 being exploited?

There is no known exploitation of CVE-2017-16043 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16043 and fix it if it is affected.

What it is: CVE-2017-16043 is a medium-severity cross-site scripting vulnerability in HackerOne shout node module, published on 4 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16043 in the wild and no public exploit code.

Affected packages and fixed versions:
- shout (npm): affected from 0.44.0; fixed in 0.50.0
- shout (npm): affected from 0.44.0; fixed in 0.50.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16043/ (Markdown: https://insights.sbomify.com/CVE-2017-16043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16043
- OSV: https://osv.dev/vulnerability/CVE-2017-16043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16043/
Summaries are generated and may contain mistakes; the official description above is the record.
