{"answers":{"affected":"2 open source packages ship an affected version, including node-tkinter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16062 in the wild and no public exploit code.","fix":"Upgrade node-tkinter to 1.0.3 or later.","what":"CVE-2017-16062 is a high-severity vulnerability in HackerOne node-tkinter node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16062 and fix it if it is affected.\n\nWhat it is: CVE-2017-16062 is a high-severity vulnerability in HackerOne node-tkinter node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16062 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- node-tkinter (npm): affected all versions; fixed in 1.0.3\n- node-tkinter (npm): affected all versions; fixed in 1.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16062/ (Markdown: https://insights.sbomify.com/CVE-2017-16062/index.md)","id":"CVE-2017-16062","markdown":"https://insights.sbomify.com/CVE-2017-16062/index.md","name":"CVE-2017-16062","record":{"aliases":["GHSA-mwcv-m549-5cm8"],"analysis":{"component_type":"library","fix_type":"end_of_life","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"npm malicious module","requires_auth":"none","summary":"A malicious npm module hijacked environment variables, exposing sensitive data to attackers via supply chain compromise.","user_interaction":"not_required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"node-tkinter","vendor":"node-tkinter_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"},{"id":"CWE-506","name":"Embedded Malicious Code"}],"description":"node-tkinter was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"node-tkinter is malware","id":"CVE-2017-16062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"supply_chain","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"node-opensl is malware","id":"CVE-2017-16063"},"packages":[{"ecosystem":"npm","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"node-tkinter","purl":null,"source":"GHSA-mwcv-m549-5cm8"},{"ecosystem":"npm","fixed":["1.0.3"],"introduced":["0"],"last_affected":[],"package":"node-tkinter","purl":"pkg:npm/node-tkinter","source":"GHSA-mwcv-m549-5cm8"}],"prev":{"headline":"tkinter is malware","id":"CVE-2017-16061"},"products":["node-tkinter node module"],"published":"2018-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"A malicious npm module hijacked environment variables, exposing sensitive data to attackers via supply chain compromise.","url":"https://insights.sbomify.com/CVE-2017-16062/"}