# CVE-2017-16062: node-tkinter is malware

> A malicious npm module hijacked environment variables, exposing sensitive data to attackers via supply chain compromise.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-mwcv-m549-5cm8

## What is CVE-2017-16062?

CVE-2017-16062 is a high-severity vulnerability in HackerOne node-tkinter node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

node-tkinter was a malicious module published with the intent to hijack environment variables. It has been unpublished by npm.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-506 (Embedded Malicious Code)

## Which versions are affected by CVE-2017-16062?

2 open source packages ship an affected version, including node-tkinter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-tkinter` | npm | All versions | 1.0.3 |
| `node-tkinter` | npm | All versions | 1.0.3 |

Products: Node-Tkinter Project Node-Tkinter.

## How do I fix CVE-2017-16062?

Upgrade node-tkinter to 1.0.3 or later.

## Is CVE-2017-16062 being exploited?

There is no known exploitation of CVE-2017-16062 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16062 and fix it if it is affected.

What it is: CVE-2017-16062 is a high-severity vulnerability in HackerOne node-tkinter node module, published on 29 May 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16062 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-tkinter (npm): affected all versions; fixed in 1.0.3
- node-tkinter (npm): affected all versions; fixed in 1.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16062/ (Markdown: https://insights.sbomify.com/CVE-2017-16062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16062
- OSV: https://osv.dev/vulnerability/CVE-2017-16062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16062/
Summaries are generated and may contain mistakes; the official description above is the record.
