# CVE-2017-16083: Directory Traversal in node-simple-router

> An attacker can access arbitrary files on the server by manipulating URL paths in the node-simple-router library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5w8q-x7hc-jhp6

## What is CVE-2017-16083?

CVE-2017-16083 is a high-severity path traversal vulnerability in HackerOne node-simple-router node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

node-simple-router is a minimalistic router for Node. node-simple-router is vulnerable to a directory traversal issue, giving an attacker access to the filesystem by placing "../" in the URL.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2017-16083?

2 open source packages ship an affected version, including node-simple-router. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-simple-router` | npm | All versions | 0.10.1 |
| `node-simple-router` | npm | All versions | 0.10.1 |

Products: Node-Simple-Router Node-Simple-Router.

## How do I fix CVE-2017-16083?

Upgrade node-simple-router to 0.10.1 or later.

## Is CVE-2017-16083 being exploited?

There is no known exploitation of CVE-2017-16083 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16083 and fix it if it is affected.

What it is: CVE-2017-16083 is a high-severity path traversal vulnerability in HackerOne node-simple-router node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16083 in the wild and no public exploit code.

Affected packages and fixed versions:
- node-simple-router (npm): affected all versions; fixed in 0.10.1
- node-simple-router (npm): affected all versions; fixed in 0.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16083/ (Markdown: https://insights.sbomify.com/CVE-2017-16083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16083
- OSV: https://osv.dev/vulnerability/CVE-2017-16083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16083/
Summaries are generated and may contain mistakes; the official description above is the record.
