{"answers":{"affected":"2 open source packages ship an affected version, including charset. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16098 in the wild and no public exploit code.","fix":"Upgrade charset to 1.0.1 or later.","what":"CVE-2017-16098 is a high-severity denial of service vulnerability in HackerOne charset node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16098 and fix it if it is affected.\n\nWhat it is: CVE-2017-16098 is a high-severity denial of service vulnerability in HackerOne charset node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16098 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- charset (npm): affected all versions; fixed in 1.0.1\n- charset (npm): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16098/ (Markdown: https://insights.sbomify.com/CVE-2017-16098/index.md)","id":"CVE-2017-16098","markdown":"https://insights.sbomify.com/CVE-2017-16098/index.md","name":"CVE-2017-16098","record":{"aliases":["GHSA-9cp3-fh5x-xfcj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js charset module","requires_auth":"none","summary":"Attackers can cause denial of service in the charset Node.js module via regular expression complexity, though impact is limited by default header size constraints.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"charset","vendor":"charset_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"charset 1.0.0 and below are vulnerable to regular expression denial of service. Input of around 50k characters is required for a slow down of around 2 seconds. Unless node was compiled using the -DHTTP_MAX_HEADER_SIZE= option the default header max length is 80kb, so the impact of the ReDoS is relatively low.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regular Expression Denial of Service in charset","id":"CVE-2017-16098","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Regular Expression Denial of Service in no-case","id":"CVE-2017-16099"},"packages":[{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"charset","purl":null,"source":"GHSA-9cp3-fh5x-xfcj"},{"ecosystem":"npm","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"charset","purl":"pkg:npm/charset","source":"GHSA-9cp3-fh5x-xfcj"}],"prev":{"headline":"Directory Traversal in tiny-http","id":"CVE-2017-16097"},"products":["charset node module"],"published":"2018-06-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"Attackers can cause denial of service in the charset Node.js module via regular expression complexity, though impact is limited by default header size constraints.","url":"https://insights.sbomify.com/CVE-2017-16098/"}