# CVE-2017-16099: Regular Expression Denial of Service in no-case

> Attackers can cause denial of service in applications using the no-case module by submitting malicious input that blocks the event loop.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-ff6r-5jwm-8292

## What is CVE-2017-16099?

CVE-2017-16099 is a high-severity denial of service vulnerability in HackerOne no-case node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The no-case module is vulnerable to regular expression denial of service. When malicious untrusted user input is passed into no-case it can block the event loop causing a denial of service condition.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2017-16099?

2 open source packages ship an affected version, including no-case. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `no-case` | npm | All versions | 2.3.2 |
| `no-case` | npm | All versions | 2.3.2 |

Products: No-Case Project No-Case.

## How do I fix CVE-2017-16099?

Upgrade no-case to 2.3.2 or later.

## Is CVE-2017-16099 being exploited?

There is no known exploitation of CVE-2017-16099 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16099 and fix it if it is affected.

What it is: CVE-2017-16099 is a high-severity denial of service vulnerability in HackerOne no-case node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16099 in the wild and no public exploit code.

Affected packages and fixed versions:
- no-case (npm): affected all versions; fixed in 2.3.2
- no-case (npm): affected all versions; fixed in 2.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16099/ (Markdown: https://insights.sbomify.com/CVE-2017-16099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16099
- OSV: https://osv.dev/vulnerability/CVE-2017-16099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16099/
Summaries are generated and may contain mistakes; the official description above is the record.
