{"answers":{"affected":"2 open source packages ship an affected version, including dns-sync. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16100 in the wild and no public exploit code.","fix":"Upgrade dns-sync to 0.1.1 or later.","what":"CVE-2017-16100 is a critical command injection vulnerability in HackerOne dns-sync node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16100 and fix it if it is affected.\n\nWhat it is: CVE-2017-16100 is a critical command injection vulnerability in HackerOne dns-sync node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16100 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dns-sync (npm): affected all versions; fixed in 0.1.1\n- dns-sync (npm): affected all versions; fixed in 0.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16100/ (Markdown: https://insights.sbomify.com/CVE-2017-16100/index.md)","id":"CVE-2017-16100","markdown":"https://insights.sbomify.com/CVE-2017-16100/index.md","name":"CVE-2017-16100","record":{"aliases":["GHSA-jcw8-r9xm-32c6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js DNS resolver","requires_auth":"none","summary":"Attackers can execute arbitrary commands via untrusted input in the dns-sync library's resolve method, requiring immediate library upgrades.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"dns-sync","vendor":"dns-sync_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"dns-sync is a sync/blocking dns resolver. If untrusted user input is allowed into the resolve() method then command injection is possible.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command Injection in dns-sync","id":"CVE-2017-16100","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Directory Traversal in serverwg","id":"CVE-2017-16101"},"packages":[{"ecosystem":"npm","fixed":["0.1.1"],"introduced":["0"],"last_affected":[],"package":"dns-sync","purl":null,"source":"GHSA-jcw8-r9xm-32c6"},{"ecosystem":"npm","fixed":["0.1.1"],"introduced":["0"],"last_affected":[],"package":"dns-sync","purl":"pkg:npm/dns-sync","source":"GHSA-jcw8-r9xm-32c6"}],"prev":{"headline":"Regular Expression Denial of Service in no-case","id":"CVE-2017-16099"},"products":["dns-sync node module"],"published":"2018-06-07","related":[{"cvss_score":10,"headline":"dns-sync command injection vulnerability","id":"CVE-2014-9682","kev_date_added":null,"published":"2015-02-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can execute arbitrary commands via untrusted input in the dns-sync library's resolve method, requiring immediate library upgrades.","url":"https://insights.sbomify.com/CVE-2017-16100/"}