# CVE-2017-16100: Command Injection in dns-sync

> Attackers can execute arbitrary commands via untrusted input in the dns-sync library's resolve method, requiring immediate library upgrades.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-jcw8-r9xm-32c6

## What is CVE-2017-16100?

CVE-2017-16100 is a critical command injection vulnerability in HackerOne dns-sync node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dns-sync is a sync/blocking dns resolver. If untrusted user input is allowed into the resolve() method then command injection is possible.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2017-16100?

2 open source packages ship an affected version, including dns-sync. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dns-sync` | npm | All versions | 0.1.1 |
| `dns-sync` | npm | All versions | 0.1.1 |

Products: Dns-Sync Project Dns-Sync.

## How do I fix CVE-2017-16100?

Upgrade dns-sync to 0.1.1 or later.

## Is CVE-2017-16100 being exploited?

There is no known exploitation of CVE-2017-16100 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne dns-sync node module

- [CVE-2014-9682](https://insights.sbomify.com/CVE-2014-9682/): dns-sync command injection vulnerability (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16100 and fix it if it is affected.

What it is: CVE-2017-16100 is a critical command injection vulnerability in HackerOne dns-sync node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16100 in the wild and no public exploit code.

Affected packages and fixed versions:
- dns-sync (npm): affected all versions; fixed in 0.1.1
- dns-sync (npm): affected all versions; fixed in 0.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16100/ (Markdown: https://insights.sbomify.com/CVE-2017-16100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16100
- OSV: https://osv.dev/vulnerability/CVE-2017-16100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16100/
Summaries are generated and may contain mistakes; the official description above is the record.
