{"answers":{"affected":"2 open source packages ship an affected version, including superagent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16129 in the wild and no public exploit code.","fix":"Upgrade superagent to 3.7.0 or later.","what":"CVE-2017-16129 is a medium-severity denial of service vulnerability in HackerOne superagent node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16129 and fix it if it is affected.\n\nWhat it is: CVE-2017-16129 is a medium-severity denial of service vulnerability in HackerOne superagent node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16129 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- superagent (npm): affected all versions; fixed in 3.7.0\n- superagent (npm): affected all versions; fixed in 3.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16129/ (Markdown: https://insights.sbomify.com/CVE-2017-16129/index.md)","id":"CVE-2017-16129","markdown":"https://insights.sbomify.com/CVE-2017-16129/index.md","name":"CVE-2017-16129","record":{"aliases":["DEBIAN-CVE-2017-16129","GHSA-8225-6cvr-8pqp","UBUNTU-CVE-2017-16129"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"An attacker controlling the request URL can cause excessive resource consumption via ZIP bomb responses, leading to denial of service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"superagent","vendor":"superagent_project"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"},{"id":"CWE-409","name":"Improper Handling of Highly Compressed Data (Data Amplification)"}],"description":"The HTTP client module superagent is vulnerable to ZIP bomb attacks. In a ZIP bomb attack, the HTTP server replies with a compressed response that becomes several magnitudes larger once uncompressed. If a client does not take special care when processing such responses, it may result in excessive CPU and/or memory consumption. An attacker might exploit such a weakness for a DoS attack. To exploit this the attacker must control the location (URL) that superagent makes a request to.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"superagent vulnerable to zip bomb attacks","id":"CVE-2017-16129","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Directory Traversal in exxxxxxxxxxx","id":"CVE-2017-16130"},"packages":[{"ecosystem":"npm","fixed":["3.7.0"],"introduced":["0"],"last_affected":[],"package":"superagent","purl":null,"source":"GHSA-8225-6cvr-8pqp"},{"ecosystem":"npm","fixed":["3.7.0"],"introduced":["0"],"last_affected":[],"package":"superagent","purl":"pkg:npm/superagent","source":"GHSA-8225-6cvr-8pqp"}],"prev":{"headline":"npm-script-demo is malware","id":"CVE-2017-16128"},"products":["superagent node module"],"published":"2018-06-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["HackerOne"]},"summary":"An attacker controlling the request URL can cause excessive resource consumption via ZIP bomb responses, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2017-16129/"}