# CVE-2017-16129: superagent vulnerable to zip bomb attacks

> An attacker controlling the request URL can cause excessive resource consumption via ZIP bomb responses, leading to denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-16129, GHSA-8225-6cvr-8pqp, UBUNTU-CVE-2017-16129

## What is CVE-2017-16129?

CVE-2017-16129 is a medium-severity denial of service vulnerability in HackerOne superagent node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The HTTP client module superagent is vulnerable to ZIP bomb attacks. In a ZIP bomb attack, the HTTP server replies with a compressed response that becomes several magnitudes larger once uncompressed. If a client does not take special care when processing such responses, it may result in excessive CPU and/or memory consumption. An attacker might exploit such a weakness for a DoS attack. To exploit this the attacker must control the location (URL) that superagent makes a request to.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2017-16129?

2 open source packages ship an affected version, including superagent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `superagent` | npm | All versions | 3.7.0 |
| `superagent` | npm | All versions | 3.7.0 |

Products: Superagent Project Superagent.

## How do I fix CVE-2017-16129?

Upgrade superagent to 3.7.0 or later.

## Is CVE-2017-16129 being exploited?

There is no known exploitation of CVE-2017-16129 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16129 and fix it if it is affected.

What it is: CVE-2017-16129 is a medium-severity denial of service vulnerability in HackerOne superagent node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16129 in the wild and no public exploit code.

Affected packages and fixed versions:
- superagent (npm): affected all versions; fixed in 3.7.0
- superagent (npm): affected all versions; fixed in 3.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16129/ (Markdown: https://insights.sbomify.com/CVE-2017-16129/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16129
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16129
- OSV: https://osv.dev/vulnerability/CVE-2017-16129

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16129/
Summaries are generated and may contain mistakes; the official description above is the record.
