{"answers":{"affected":"4 open source packages ship an affected version, including method-override. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16136 in the wild and no public exploit code.","fix":"Upgrade method-override to 2.3.10 or later.","what":"CVE-2017-16136 is a high-severity denial of service vulnerability in HackerOne method-override node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-16136 and fix it if it is affected.\n\nWhat it is: CVE-2017-16136 is a high-severity denial of service vulnerability in HackerOne method-override node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-16136 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- method-override (npm): affected from 1.0.2; fixed in 2.3.10\n- method-override (npm): affected from 1.0.2; fixed in 2.3.10\n- method-override (npm): affected from 2.0.0; fixed in 2.3.10\n- method-override (npm): affected from 2.0.0; fixed in 2.3.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16136/ (Markdown: https://insights.sbomify.com/CVE-2017-16136/index.md)","id":"CVE-2017-16136","markdown":"https://insights.sbomify.com/CVE-2017-16136/index.md","name":"CVE-2017-16136","record":{"aliases":["GHSA-qx2f-477c-35rq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js HTTP middleware","requires_auth":"none","summary":"Attackers can cause denial of service in applications using method-override by sending crafted X-HTTP-Method-Override headers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"hackerone","cpe":[{"product":"method-override","vendor":"expressjs"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"method-override ReDoS when untrusted user input passed into X-HTTP-Method-Override header","id":"CVE-2017-16136","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2017"},"n_packages":4,"n_references":1,"next":{"headline":"Regular Expression Denial of Service in debug","id":"CVE-2017-16137"},"packages":[{"ecosystem":"npm","fixed":["2.3.10"],"introduced":["1.0.2"],"last_affected":[],"package":"method-override","purl":null,"source":"GHSA-qx2f-477c-35rq"},{"ecosystem":"npm","fixed":["2.3.10"],"introduced":["1.0.2"],"last_affected":[],"package":"method-override","purl":"pkg:npm/method-override","source":"GHSA-qx2f-477c-35rq"},{"ecosystem":"npm","fixed":["2.3.10"],"introduced":["2.0.0"],"last_affected":[],"package":"method-override","purl":null,"source":"GHSA-qx2f-477c-35rq"},{"ecosystem":"npm","fixed":["2.3.10"],"introduced":["2.0.0"],"last_affected":[],"package":"method-override","purl":"pkg:npm/method-override","source":"GHSA-qx2f-477c-35rq"}],"prev":{"headline":"Directory Traversal in serverzyy","id":"CVE-2017-16135"},"products":["method-override node module"],"published":"2018-06-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["HackerOne"]},"summary":"Attackers can cause denial of service in applications using method-override by sending crafted X-HTTP-Method-Override headers.","url":"https://insights.sbomify.com/CVE-2017-16136/"}