# CVE-2017-16136: method-override ReDoS when untrusted user input passed into X-HTTP-Method-Override header

> Attackers can cause denial of service in applications using method-override by sending crafted X-HTTP-Method-Override headers.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-qx2f-477c-35rq

## What is CVE-2017-16136?

CVE-2017-16136 is a high-severity denial of service vulnerability in HackerOne method-override node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

method-override is a module used by the Express.js framework to let you use HTTP verbs such as PUT or DELETE in places where the client doesn't support it. method-override is vulnerable to a regular expression denial of service vulnerability when specially crafted input is passed in to be parsed via the X-HTTP-Method-Override header.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2017-16136?

4 open source packages ship an affected version, including method-override. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `method-override` | npm | From 1.0.2 | 2.3.10 |
| `method-override` | npm | From 1.0.2 | 2.3.10 |
| `method-override` | npm | From 2.0.0 | 2.3.10 |
| `method-override` | npm | From 2.0.0 | 2.3.10 |

Products: Expressjs Method-Override.

## How do I fix CVE-2017-16136?

Upgrade method-override to 2.3.10 or later.

## Is CVE-2017-16136 being exploited?

There is no known exploitation of CVE-2017-16136 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16136 and fix it if it is affected.

What it is: CVE-2017-16136 is a high-severity denial of service vulnerability in HackerOne method-override node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16136 in the wild and no public exploit code.

Affected packages and fixed versions:
- method-override (npm): affected from 1.0.2; fixed in 2.3.10
- method-override (npm): affected from 1.0.2; fixed in 2.3.10
- method-override (npm): affected from 2.0.0; fixed in 2.3.10
- method-override (npm): affected from 2.0.0; fixed in 2.3.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16136/ (Markdown: https://insights.sbomify.com/CVE-2017-16136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16136
- OSV: https://osv.dev/vulnerability/CVE-2017-16136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16136/
Summaries are generated and may contain mistakes; the official description above is the record.
