# CVE-2017-16138: mime Regular Expression Denial of Service when MIME lookup performed on untrusted user input

> Attackers can cause denial of service in applications using the mime library by triggering expensive regular expression operations with untrusted input.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 7 Oct 2026
- **Also known as:** CLSA-2026-1774398061, CLSA-2026-1781484843, CLSA-2026-1781484844, CLSA-2026-1784682759, CLSA-2026-1784769496, CLSA-2026-1792767387, DEBIAN-CVE-2017-16138, GHSA-wrvr-8mpx-r7pp, ROOT-APP-NPM-CVE-2017-16138, UBUNTU-CVE-2017-16138

## What is CVE-2017-16138?

CVE-2017-16138 is a high-severity denial of service vulnerability in HackerOne mime node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The mime module < 1.4.1, 2.0.1, 2.0.2 is vulnerable to regular expression denial of service when a mime lookup is performed on untrusted user input.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2017-16138?

4 open source packages ship an affected version, including mime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mime` | npm | All versions | 1.4.1 |
| `mime` | npm | All versions | 1.4.1 |
| `mime` | npm | From 2.0.0 | 2.0.3 |
| `mime` | npm | From 2.0.0 | 2.0.3 |

Products: Mime Project Mime.

## How do I fix CVE-2017-16138?

Upgrade mime to a fixed version for your release line: 1.4.1 or 2.0.3.

## Is CVE-2017-16138 being exploited?

There is no known exploitation of CVE-2017-16138 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16138 and fix it if it is affected.

What it is: CVE-2017-16138 is a high-severity denial of service vulnerability in HackerOne mime node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16138 in the wild and no public exploit code.

Affected packages and fixed versions:
- mime (npm): affected all versions; fixed in 1.4.1
- mime (npm): affected all versions; fixed in 1.4.1
- mime (npm): affected from 2.0.0; fixed in 2.0.3
- mime (npm): affected from 2.0.0; fixed in 2.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16138/ (Markdown: https://insights.sbomify.com/CVE-2017-16138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16138
- OSV: https://osv.dev/vulnerability/CVE-2017-16138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16138/
Summaries are generated and may contain mistakes; the official description above is the record.
