# CVE-2017-16224: Open Redirect in st

> An attacker can craft requests to redirect users to external domains when the module serves files from the root directory.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-72fg-jqhx-c68p

## What is CVE-2017-16224?

CVE-2017-16224 is a medium-severity vulnerability in HackerOne st node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

st is a module for serving static files. An attacker is able to craft a request that results in an HTTP 301 (redirect) to an entirely different domain. A request for: http://some.server.com//nodesecurity.org/%2e%2e would result in a 301 to //nodesecurity.org/%2e%2e which most browsers treat as a proper redirect as // is translated into the current schema being used. Mitigating factor: In order for this to work, st must be serving from the root of a server (/) rather than the typical sub directory (/static/) and the redirect URL will end with some form of URL encoded .. ("%2e%2e", "%2e.", ".%2e").

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2017-16224?

2 open source packages ship an affected version, including st. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `st` | npm | All versions | 1.2.2 |
| `st` | npm | All versions | 1.2.2 |

Products: St Project St.

## How do I fix CVE-2017-16224?

Upgrade st to 1.2.2 or later.

## Is CVE-2017-16224 being exploited?

There is no known exploitation of CVE-2017-16224 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16224 and fix it if it is affected.

What it is: CVE-2017-16224 is a medium-severity vulnerability in HackerOne st node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16224 in the wild and no public exploit code.

Affected packages and fixed versions:
- st (npm): affected all versions; fixed in 1.2.2
- st (npm): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16224/ (Markdown: https://insights.sbomify.com/CVE-2017-16224/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16224
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16224
- OSV: https://osv.dev/vulnerability/CVE-2017-16224

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16224/
Summaries are generated and may contain mistakes; the official description above is the record.
