# CVE-2017-16225: Github Token Leak in aegir

> The aegir module inadvertently exposed user GitHub tokens in published npm packages, allowing attackers to steal credentials.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6xhf-x49c-m5m6

## What is CVE-2017-16225?

CVE-2017-16225 is a high-severity vulnerability in HackerOne aegir node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

aegir is a module to help automate JavaScript project management. Version 12.0.0 through and including 12.0.7 bundled and published to npm the user (that performed a aegir-release) GitHub token.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-16225?

2 open source packages ship an affected version, including aegir. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aegir` | npm | From 12.0.0 | 12.0.8 |
| `aegir` | npm | From 12.0.0 | 12.0.8 |

Products: Aegir Project Aegir.

## How do I fix CVE-2017-16225?

Upgrade aegir to 12.0.8 or later.

## Is CVE-2017-16225 being exploited?

There is no known exploitation of CVE-2017-16225 in the wild and no public exploit code.

## Other vulnerabilities in HackerOne aegir node module

- [CVE-2020-11059](https://insights.sbomify.com/CVE-2020-11059/): Exposure of Sensitive Information to an Unauthorized Actor in AEgir (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16225 and fix it if it is affected.

What it is: CVE-2017-16225 is a high-severity vulnerability in HackerOne aegir node module, published on 7 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16225 in the wild and no public exploit code.

Affected packages and fixed versions:
- aegir (npm): affected from 12.0.0; fixed in 12.0.8
- aegir (npm): affected from 12.0.0; fixed in 12.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16225/ (Markdown: https://insights.sbomify.com/CVE-2017-16225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16225
- OSV: https://osv.dev/vulnerability/CVE-2017-16225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16225/
Summaries are generated and may contain mistakes; the official description above is the record.
