{"answers":{"affected":"2 open source packages ship an affected version, including ox. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-16229 in the wild and no public exploit code.","fix":"Upgrade ox to 2.8.2 or later.","what":"CVE-2017-16229 is a medium-severity memory corruption vulnerability in n/a, published on 26 Feb 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-16229 and fix it if it is affected.\n\nWhat it is: CVE-2017-16229 is a medium-severity memory corruption vulnerability in n/a, published on 26 Feb 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-16229 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ox (RubyGems): affected all versions; fixed in 2.8.2\n- ox (RubyGems): affected all versions; fixed in 2.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-16229/ (Markdown: https://insights.sbomify.com/CVE-2017-16229/index.md)","id":"CVE-2017-16229","markdown":"https://insights.sbomify.com/CVE-2017-16229/index.md","name":"CVE-2017-16229","record":{"aliases":["DEBIAN-CVE-2017-16229","GHSA-wfwm-chj7-w59r","UBUNTU-CVE-2017-16229"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ruby XML parser","requires_auth":"none","summary":"A stack-based buffer over-read in the Ox Ruby gem allows attackers to cause a denial of service via crafted XML input.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ox","vendor":"ox_project"}],"cvss":{"score":5.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"In the Ox gem 2.8.1 for Ruby, the process crashes with a stack-based buffer over-read in the read_from_str function in sax_buf.c when a crafted input is supplied to sax_parse.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ox gem stack overflow in sax_parse","id":"CVE-2017-16229","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"memory_corruption","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-16230"},"packages":[{"ecosystem":"RubyGems","fixed":["2.8.2"],"introduced":["0"],"last_affected":[],"package":"ox","purl":null,"source":"GHSA-wfwm-chj7-w59r"},{"ecosystem":"RubyGems","fixed":["2.8.2"],"introduced":["0"],"last_affected":[],"package":"ox","purl":"pkg:gem/ox","source":"GHSA-wfwm-chj7-w59r"}],"prev":{"headline":"Dulwich RCE Vulnerability","id":"CVE-2017-16228"},"products":["n/a"],"published":"2018-02-26","related":[{"cvss_score":7.5,"headline":"Ox gem crashes due to a crafted input","id":"CVE-2017-15928","kev_date_added":null,"published":"2017-10-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A stack-based buffer over-read in the Ox Ruby gem allows attackers to cause a denial of service via crafted XML input.","url":"https://insights.sbomify.com/CVE-2017-16229/"}