# CVE-2017-16229: Ox gem stack overflow in sax_parse

> A stack-based buffer over-read in the Ox Ruby gem allows attackers to cause a denial of service via crafted XML input.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Feb 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-16229, GHSA-wfwm-chj7-w59r, UBUNTU-CVE-2017-16229

## What is CVE-2017-16229?

CVE-2017-16229 is a medium-severity memory corruption vulnerability in n/a, published on 26 Feb 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

In the Ox gem 2.8.1 for Ruby, the process crashes with a stack-based buffer over-read in the read_from_str function in sax_buf.c when a crafted input is supplied to sax_parse.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2017-16229?

2 open source packages ship an affected version, including ox. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ox` | RubyGems | All versions | 2.8.2 |
| `ox` | RubyGems | All versions | 2.8.2 |

Products: Ox Project Ox.

## How do I fix CVE-2017-16229?

Upgrade ox to 2.8.2 or later.

## Is CVE-2017-16229 being exploited?

There is no known exploitation of CVE-2017-16229 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-15928](https://insights.sbomify.com/CVE-2017-15928/): Ox gem crashes due to a crafted input (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16229 and fix it if it is affected.

What it is: CVE-2017-16229 is a medium-severity memory corruption vulnerability in n/a, published on 26 Feb 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16229 in the wild and no public exploit code.

Affected packages and fixed versions:
- ox (RubyGems): affected all versions; fixed in 2.8.2
- ox (RubyGems): affected all versions; fixed in 2.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16229/ (Markdown: https://insights.sbomify.com/CVE-2017-16229/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16229
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16229
- OSV: https://osv.dev/vulnerability/CVE-2017-16229

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16229/
Summaries are generated and may contain mistakes; the official description above is the record.
