# CVE-2017-16244: October CMS CSRF

> An attacker can take over a victim's account in OctoberCMS by bypassing CSRF protections via a specific postback variable.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Nov 2017
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vm6r-4p4v-232x

## What is CVE-2017-16244?

CVE-2017-16244 is a high-severity vulnerability in Octobercms October, published on 1 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-Site Request Forgery exists in OctoberCMS 1.0.426 (aka Build 426) due to improper validation of CSRF tokens for postback handling, allowing an attacker to successfully take over the victim's account. The attack bypasses a protection mechanism involving X-CSRF headers and CSRF tokens via a certain _handler postback variable.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2017-16244?

2 open source packages ship an affected version, including october/october. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/october` | Packagist | All versions | 1.0.427 |
| `october/october` | Packagist | All versions | 1.0.427 |

Products: Octobercms October.

## How do I fix CVE-2017-16244?

Upgrade october/october to 1.0.427 or later.

## Is CVE-2017-16244 being exploited?

There is no known exploitation of CVE-2017-16244 in the wild and no public exploit code.

Public exploit code:

- OctoberCMS 1.0.426 (Build 426) - Cross-Site Request Forgery (exploitdb)

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16244 and fix it if it is affected.

What it is: CVE-2017-16244 is a high-severity vulnerability in Octobercms October, published on 1 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-16244 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/october (Packagist): affected all versions; fixed in 1.0.427
- october/october (Packagist): affected all versions; fixed in 1.0.427

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16244/ (Markdown: https://insights.sbomify.com/CVE-2017-16244/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16244
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16244
- OSV: https://osv.dev/vulnerability/CVE-2017-16244

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16244/
Summaries are generated and may contain mistakes; the official description above is the record.
