# CVE-2017-16355: Phusion Passenger information disclosure

> An attacker can read arbitrary files on the system by exploiting a symlink vulnerability in Phusion Passenger when running as root.

- **Severity:** Medium 4.7 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2017
- **Updated:** 5 Aug 2024
- **Also known as:** CVE-2017-1000384, DEBIAN-CVE-2017-16355, DSA-4415-1, GHSA-cv3f-px9r-54hm, UBUNTU-CVE-2017-16355

## What is CVE-2017-16355?

CVE-2017-16355 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 14 Dec 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In agent/Core/SpawningKit/Spawner.h in Phusion Passenger 5.1.10 (fixed in Passenger Open Source 5.1.11 and Passenger Enterprise 5.1.10), if Passenger is running as root, it is possible to list the contents of arbitrary files on a system by symlinking a file named REVISION from the application root folder to a file of choice and querying passenger-status --show=xml.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2017-16355?

2 open source packages ship an affected version, including passenger. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `passenger` | RubyGems | All versions | 5.1.11 |
| `passenger` | RubyGems | All versions | 5.1.11 |

Products: Debian Debian Linux, Phusion Passenger.

## How do I fix CVE-2017-16355?

Upgrade passenger to 5.1.11 or later.

## Is CVE-2017-16355 being exploited?

There is no known exploitation of CVE-2017-16355 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-16355 and fix it if it is affected.

What it is: CVE-2017-16355 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 14 Dec 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-16355 in the wild and no public exploit code.

Affected packages and fixed versions:
- passenger (RubyGems): affected all versions; fixed in 5.1.11
- passenger (RubyGems): affected all versions; fixed in 5.1.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-16355/ (Markdown: https://insights.sbomify.com/CVE-2017-16355/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-16355
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-16355
- OSV: https://osv.dev/vulnerability/CVE-2017-16355

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-16355/
Summaries are generated and may contain mistakes; the official description above is the record.
